หลังจากที่พยายามปลุกปล้ำ ให้ Mono 1.0 ให้ Compatible กับ .NET Framework 1.0, 1.1 มาได้ระยะใหญ่ และการหันไปพัฒนา Moonlight เพื่อพอร์ต Microsoft Silver Light ให้ใช้ได้กับทุก Platform และก้อปล้ำกันอยู่นานพอดูทำให้ระยะการปล่อย Mono 2.0 ล่าช้าออกไปด้วย ตอนนี้แฟนๆ Mono ไม่ต้องรออีกต่อไปแล้ว Mono 2.0 ออกมาพร้อมกับการ Cross Platform อย่างแท้จริงทั้ง Windows, Unix, Linux, MacOS ซึ่งสนับสนุน Microsoft Compatible API เกือบจะทั้งหมด ซึ่งเท่าที่ผมได้ดู release note แล้วรู้สึกอุ่นใจได้ว่า API เหล่านี้ใช้ได้กับ Mono 2.0 อย่างแน่นอน

    *  ADO.NET 2.0
    * ASP.NET 2.0
    * Windows.Forms 2.0
    * System.XML 2.0
    * System.Core
    * System.Xml.Linq
    * System.Drawing 2.0

อ่าน release note เพิ่มเติมได้ครับ

PHP เพิ่มคุณสมบัติพิเศษจากการพัฒนาร่วมกับภาษาอื่นๆ อย่าง Java Bridge มาแล้ว และคราวนี้คงถึงเวลาที่ PHP จะมี Bridge เชื่อมโยงกับ .NET แล้วล่ะครับ ทีม Developer and Platform Evangelism Interoperability ของ Microsoft ประกาศการพัฒนา PHP Toolkit for ADO .NET Data Services ซึ่งจะทำให้ PHP สามารถเรียกใช้ Microsoft .NET Framework ได้ ซึ่ง toolkit ตัวนี้พัฒนาอยู่บนเว็บไซต์ชุมชนโอเพนซอร์สของ Microsoft เองชื่อ Codeplex อาจใช้ REST เป็นโครงสร้างสำหรับการสื่อสารระหว่างกัน ซึ่งทำให้นักพัฒนาที่ใช้ภาษา PHP สามารถใช้ metadata ที่ใช้ใน ADO.NET Data Services ตัวใหม่ได้เลย ตัว toolkit ยังสามารถสร้าง proxy class ในรูปแบบ XSLT ได้อีกด้วย และแน่นอนสนับสนุน RESTful :)

ที่มา – H-Online, ClodePlex

Canonical ซุ่มพัฒนาเฟรมเวิร์คใหม่สำหรับ Ubuntu ชื่อ Quickly โดยตั้งใจให้เป็นเครื่องมือเร่งการพัฒนาแอพลิเคชันให้เร็วยิ่งขึ้น เจ้า Quickly นี้เป็นเครื่องมือบน Command Line ที่สามารถสร้างโปรแกรมใหม่ๆ ได้ (generate) อย่างรวดเร็ว พร้อม build package และออกเวอร์ชันได้เลย Quickly ใช้ template ของระบบเป็นตัวสร้างซอฟต์แวร์ขึ้นมา ซึ่ง template นี้มีหลายหลายรูปแบบ ซึ่ง template เหล่านี้ช่วยให้การสร้างแอพลิเคชันได้เร็วขึ้น แอพลิเคชันที่ได้เป็นภาษา Python และ Glade ซึ่งในตัวแพคเกจและโปรแกรมที่สร้างออกมาจะมีโค้ดและเครื่องมือต่างๆ ครบครัน เพียงแค่สั่ง generate ผ่าน command line เท่านั้น เอ้าใครอยากใช้ Quickly เพื่อพัฒนาแอพลิเคชันบน Ubuntu ต้องลอง อ้อลืมบอกไปว่าใช้กับ Ubuntu 9.10 ติดตั้งได้จาก PPA ครับ

ที่มา – arstechnica, Quickly